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Introduction1. 

This manual gives a brief and practical introduc-

tion to the MyM package. PDF versions of reference 

manuals of the language and of the GIM are includ-

ed in the distribution. 

The MyM package is used to defi ne, visualize and 

run mathematical models of dynamic systems. 

MyM integrates the development, application, 

design and presentation of these models into one 

software package. 

We defi ne four roles: the model builder, the model 

user, the interface designer and the audience. They 

all use the same MyM software (see fi gure 1). 

It is possible that one person takes more than one 

role. E.g., the model builder will also explore and 

debug his model and might also be the person to 

design the interface for the target audience. MyM 

allows multiple interfaces on the same model, allow-

ing the designer to create a interface focussed on 

diff erent audiences or viewpoints.

MyM models can be distributed as stand-alone ap-

plications in which users cannot modify the math-

ematical specifi cations and can only change input 

variables selected by the developer.

Mathematical model can only be built and modi-

fi ed by anyone having a licensed version of the MyM 

package. 

Stand-alone applications can be distributed freely by 

distributing the model with the MyM Player, how-

ever the MyM software must be purchased at the 

MyM webstore at http://www.my-m.eu.

On-line documentation (user and system) is avail-

able in HTML and PDF. Acrobat Reader is required 

to read the manuals in PDF format, which is avail-

able for download at http://www.adobe.com/nl/

products/acrobat/readstep2.html
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Requirements2. 

To run a stand-alone MyM model, the MyM Viewer 

is required. 

To create or edit models users need:

a licensed version of the MyM Software, • 

a properly installed ANSI-C compiler Visual C++ 8 • 

(Visual Studio 2005 Express, Standard or Profes-

sional). 

The C compiler is needed to generate an execut-

able from the intermediate C code into which MyM 

translates the set of equations of the MyM model. 

No knowledge about the C compiler is needed to 

use MyM. 

To use the MyM development package, users need a 

PC running Microsoft® Windows® XP with Service 

Pack 2 or higher. Versions for Linux and OSX will 

become available in the near future. 

Hardware requirements depend mainly on the size 

of the models developed by the user. MyM requires 

100 MB of available disk space and at least 512 MB 

of RAM.

Figure 2 shows the MyM architecture in more detail.

The basic steps in using MyM are: 

write mathematical models using any ASCII editor • 

by writing equations in the MyM language  

MyM will turn this set of equations into an execut-• 

able simulator  (by creating intermediate c-code)

run the model using one the user interfaces:• 

a • graphical interface to design and use graphi-

cal interfaces to compiled MyM models, called 

MGIM (Graphical Interface Manager)

a • variable tracer to trace the dependen-

cies among the variables in a model, called 

MVartrace

a • text-based interpreter to control a model from 

a command prompt, named MCUI (Command 

Line Interface), or the

player• , which can be used to distribute your 

own models with a graphical user interface. The 

interface has to be designed with MGIM.
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Installation3. 

The MyM package can be downloaded from our 

website, as a self- extracting executable. 

Run the Setup executable and follow the instruc-

tions. Please review the README fi le included with 

the installation for environment variables that may 

need to be set by hand, such as M_PATH to the 

directory were MyM is being installed and C_PATH 

to the directory where the C Compiler can be found. 

The latter is needed if one wants to create new MyM 

models. 

See the Environment Appendix in the GIM Refer-

ence Manual for some additional variables that can 

be changed, for instance to aff ect the way MyM 

responds to mouse actions. 

Documentation and support4. 

The most recent information (and the latest ver-

sion) is available at the MyM Web site. The following 

documentation is available: 

this Getting Started Manual • 

a Language Tutorial • 

a Language Reference Manual • 

a Graphical Interface Reference Manual • 

an Application Programmer’s Interface Reference • 

Manual 

The distribution includes PDF versions of these 

documents that can be consulted and the GIM 

Manual can be consulted directly from the Help 

menu or directly using a HTML browser. Context-

sensitive help about specifi c interface components 

is available by placing the mouse over the item of 

interest and pressing the F1 function key. 

Please send suggestions, questions or comments to 

support@my-m.eu.
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The basic steps5. 

There are 2 ways to build MyM Models. The fi rst 

method is to use the � � � ��  command on the 

command-line. The second method is to use the 

Integrated Development Environment (IDE) named 

MStudio.  We will discuss MStudio in the next sec-

tion.

Let’s take a brief look at the steps needed to create 

a simple model. We will use a simple model of water 

cascading through a couple of buckets as our ex-

ample. This casc (cascade) model is included in the 

distribution, in the samples directory. Use any ASCII 

text editor to look at the casc.m fi le. (Always use the 

.m extension for fi les with MyM source code). 

The MyM Language Tutorial takes you step by step 

through the mathematical formulation of this mod-

el. The MyM Language Reference Manual contains a 

full description of the MyM language. 

To compile the model casc.m on command-line 

you fi rst have to open a command prompt (type 

cmd at Windows Start->run) and change the current 

directory to the directory where the MyM model is 

located.

Then use the command 

 � �� � � � � � � 
to generate casc.c, the fi le to be passed to the C 

compiler. The m2c command does syntax checking 

and accepts various fl ags to allow run-time error 

checking on array bounds and fl oating-point calcula-

tions. Type 

 � �� � 	 � 
�  

for an overview of the available options.

Once a MyM model has been successfully translated 

into C, actual compilation is done by issuing the 

command: � � � �� � �  � 
 � �  

mmake casc.mdl generates a simulator that can be 

loaded dynamically during run-time into any of the 

three general interfaces included in the distribution, 

i.e.: MGIM, MCUI or MVARTRACE
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� � � � � � � �� � � �

• runs the graphical interface for 

the casc model � � � � � � � �� � � �

• runs the command-line inter-

face for the casc model� � � � � � � � � � � � �� � � �

•  runs the tracer of the 

variables in the casc model. 

The CUI interface should be self-explanatory (type 

HELP at the prompt), as should Vartrace. 

In the next section we discuss the Integrated 

Development Environment as a more user-friendly 

method to create MyM models.

In the remaining sections we will concentrate on the 

more complex and more powerful Graphical Inter-

face Manager MGIM. 
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Using MyM Studio6. 

MStudio was fi rst introduced in version 6 of the 

MyM Software. It off ers the user a graphical user 

interface to build MyM models.

Using an Integrated Development Environment 

saves you time in developing models, by managing 

editors, settings, and compilation of MyM models. 

By using MyM Studio the modeler does not need to 

use command line, but can just develop the models 

in the graphical IDE.

Source editing, compilation of the model, and 

generation of the simulation model are integrated 

in MStudio. Highlighted code and an error output 

window gives you the necessary feedback for writing 

MyM models.

Project
When you launch MStudio it opens with an empty 

project with no name. 

Within MStudio, you work within the context of a 

project, which consists of a group of source fi les and 

associated metadata; project specifi c properties; 

and all the tools you will need to write and compile 

your source code into an executable MyM model. 

First you have to give the project a name and save 

the project to disk.

Once you give MyM Studio the new project name, it 

updates the project tree.

From there you either add an existing MyM fi le (like 

casc.m) to the Project by using Project->Add existing 

item or use Project->Add new item from the menu 

bar. It will add a fi le to the project’s source tree and 

it will open it a new editor. The fi rst fi le added will 

also be made target of the Project by default.

The project’s target is the main MyM fi le that con-

tains the model and will be converted into a .mdl 

model in the compilation process.

The Project window displays the fi les that you want 

to be regularly edited, such as the source fi les of 

your model.
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Double-click on a source fi le automatically opens 

the fi le in the workspace at the right-hand side in a 

new or existing source Editor. 

It is also possible to exclude a fi le from the project, 

by selecting the fi le in the Project window and se-

lecting Project->exclude item from the menu or right 

click the fi le in the source tree and select “exclude”.

Using the Source Editor 

In the Source Editor the user can write MyM code 

for the model. When you write equations this way, 

you will notice that the editor automatically high-

lights the code in color.

Source Editor Options
You can change the font of the source  editors by 

going to Options->Font

You can jump to a certain line by using Ctrl+G inside 

the editor’s window or Select Edit->Goto Line.

Setting project properties
The properties of a project determine how the 

model will be built.

Compilation of a MyM model is done in 2 stages. 

First the MyM fi le is translated into C code and then 

by using the Microsoft Visual Studio C Compiler it is 

translated into an executable MyM model. 

In the project properties you can set the target 

model, additional fl ags for compilation in the m2c 

compilation process and compiler options.

MyM Studio will try set defaults for the options.

If the options are not set by default you would have 

to enter them.

The most important options are:

MyM directory
The path to the MyM directory you selected during 

installation.

Type C++ compiler
Currently MyM only supports the Visual Studio 

Compiler 2005, selected by the name “VC8”. Cur-

rently you cannot change this value, because VC8 is 

the only supported compiler.
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Path C++ Compiler
The path to where the Microsoft Visual C++ 2005 

executables are installed, typically 

C:/Program Files/Microsoft Visual Studio 8/VC/bin. 

Do not change this value if MyM Studio set it for 

you.

Building MyM Models
Make sure you have the Visual Studio 2005 C++ 

Compiler installed before you try to build a MyM 

model.

Before you can compile a model  you also need to 

have one MyM source fi le in the project browser to 

be selected as the target. The target source fi le is 

indicated by a bold font. If none of the fi les in the 

project fi le browser is selected, select a source fi le 

and then select Project->Set as project target in the 

menu bar.

There are two stages in the model build process. 

First a compilation and then the actual building of 

the simulator.

You can see which source fi le is selected as the tar-

get model and will be compiled or built by selecting 

the  General tab of the Project properties dialog.

To compile a model and check for syntax errors 

select Build->Compile form the menu bar.

If there are no errors in the output window, you can 

start building the model. It might be that the com-

pilation process generated warnings. Please read 

them carefully and doublecheck that these warnings 

will not cause future problems.

From that moment you can build a model by going 

to Build->Build model.  
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Designing a graphical interface7. 

Start the graphical interface of MyM, by double-

clicking in the File Manager or typing MGIM at a 

command prompt. 

MGIM will bring up an empty window with a menu 

and tool bar along the top. 

In the general MGIM (when no model is linked yet), 

the File->Load Model menu option should be used 

fi rst to load a model. This should be the compiled 

version (e.g. casc.mdl), not the source code version 

(e.g. casc.m). 

In our example we will use the GIM in the 

samples/casc directory, where the model is already 

compiled to an executable simulator. 

To see how an interface of the cascade model could 

look like, select the View Manager in the Tools 

menu. In MyM any number of views on a model can 

be defi ned and kept around. Initially only an (empty) 

default view is available. 

Load a predefi ned view by clicking on View->Load... 

and use the fi le browser to load casc.vdf from the 

samples/casc directory. 

A VDF or View Defi nition File is a data fi le contain-

ing the defi nition of a particular view: which vari-

ables are included and how they are presented and 

(hierarchically) organized. Do not edit these fi les 

outside the graphical interface, as they can easily 

become corrupt and unusable. 
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Exploring a view8. 

If you load a view a couple of (closed) containers 

will appear in the window. 

To get a complete overview, put your mouse any-

where outside any container and press the right 

button. A pop-up menu will appear, select Open 

All. The sliders and graphs shown visualize all main 

variables in casc. 

Click Right on some box and select Zoom In or 

Zoom Out from the context menu to explore the 

various components in more detail. 

Editing model inputs9. 

Input variables are variables that do not depend on 

other variables, i.e. they have no arrows pointing 

at them1. Input variables can be edited directly, for 

instance by placing the mouse over a slider, pressing 

left and dragging. 

While sliders represent constants. i.e. variables that 

do not change over time, line graphs represent-

ing time-dependent functions can also be edited 

directly. 

This is done by redrawing the graph using a left-

drag, i.e. by dragging the mouse while pressing the 

left button. Doing so resets the function for specifi c 

domain values2. 

Another way to fi nd out whether a variable is an input variable is by pointing at it and pressing Ctrl-E. For input variables nothing will happen, 1. 

for dependent variables this will bring up the equation for that variable. 

Which domain values is determined by the values used in the initialization statement in the M model: a(t) = [1, 0, 10, 0] means that only the 2. 

value for t = 1 and t = 10 can be changed. To allow a higher resolution, add more values to this initial set, e.g.a(t) = [1, 0, 2, 0, 3, 0, 5, 0, 10, 0]. 
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Various options are available, including a Table Edi-

tor in which the numbers can be typed in directly. 

Mouse-right over the graph displays the options. 

The Load (and Save) options are one way of using 

previously defi ned data stored in MyM format. See 

the section on Scenarios in the MyM Graphical User 

Interface Reference Manual for further details. 
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Changing appearances10. 

Any MyM variable in MGIM is characterized by its 

range, its domain (unless it is a constant) and its 

dimensionality: 

range•  – the minimum and maximum values 

shown, the unit, sub-ranges etc. 

domain•  – the minimum and maximum time value, 

unit etc. 

dimensionality•  – as MyM variables can have any 

number of indices or dimensions, of any size, a 

mechanism is needed to keep track of the sub-

set selected for visualization; depending on the 

graphical type used (line graph, grid map, bar-

chart) up to two dimensions can be selected, and 

from these one or more values (classes).

To edit these aspects, the appropriate dialog can be 

selected from the Edit menu.

The Widget option under Edit is used to select the 

type of graph and to select the dimensions, the Di-

mension dialog is used to select values within those 

dimensions. 

The Layout dialog is used to set the appearance at-

tributes of the widget, like colors, font, etc.
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Modes11. 

The Layout dialog is only available in Design mode 

(select Design in the Mode menu). 

 

This mode is also needed to add items (the New 

menu), to cut-and-paste items (in the Edit menu) 

or for access to the advanced options in the various 

Edit dialogs that are activated by pressing the button 

with the >> label. 

Press this button to select or edit templates for 

ranges, domains or dimensions. 

Templates12. 

The specifi cations for ranges, domains and dimen-

sions are stored in named templates that can be 

used for multiple variables. Doing so ensures that 

these variables use the same scales, units, labels 

and color codings. 

By editing a template, e.g. selecting a diff erent set of 

values on a dimension or changing a color coding, 

all variables using that template will be updated 

automatically. 

This also happens when a range is edited directly by 

scaling or dragging with the mouse. 
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Adding variables13. 

To add a variable to a view, make sure you are in 

Design Mode and select the Variable option in the 

New menu. 

A variable browser will appear showing all variables 

not yet contained in the currently active view. If you 

do this in the view included, an empty list will ap-

pear, as all variables have been used. 

Use the View manager (in the View menu) to go 

back to the empty (Default) view and try again. 

Select a variable with mouse-left, put your mouse 

somewhere in the window and drag-left to deter-

mine the size of the new box. 

To add several variables, keep the Shift pressed to 

prevent the variable browser from disappearing. 

To group items, select Container under New and 

draw a box over the items (i.e. variables or contain-

ers), by drag-left. 

Components can also be added or removed by mov-

ing them around. 

Items are resized by dragging their borders with the 

left mouse key, and moved by pressing the Alt- key 

during a drag-left. 

Grouping, moving and resizing items14. 
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Looking at diff erent views15. 

Using the View Manager, one can load existing views 

and switch between views

It is also possible to split the window (using the Split 

menu in the menu Window) and to select the same 

or diff erent views for each pane. 

When looking at diff erent instances of the same 

view, zooming can be synchronized (in the View 

manager). 

Saving and loading data16. 

There are several ways to handle data input/output:

direct manipulation of sliders and graphs • 

the Table Editor (from the Tools menu or the right-• 

mouse pop-up menu) 

use of the Load and Save options in the right-• 

mouse pop-up menu 

use of the FILE construct in the MyM source code • 

for a model (or of the PROG construct to execute 

a shell command to read or write data). For more 

information about the FILE contruct consult sec-

tion “Variable Declarations” in the MyM Language 

Reference Manual.

use of the Scenario Manager in the Tools menu • 

(see the next section). 

Although a Load or Save on a container (3rd option) 

will set or store all variables within that container, 

options 1 to 4 are basically intended to deal with one 

variable at a time. 
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Scenarios17. 

To read and save sets of variables and provide a 

systematic handling of data storage, use of the sce-

nario manager is recommended. The term scenario 

is used loosely in this context, it referes to any set of 

variables that are handled as a set. A scenario can 

be restricted to all or some inputs, to all or some 

outputs or to combinations of inputs, outputs and 

intermediate variables. (Obviously, all non-input 

variables will be recomputed when the model is 

run). 

Scenarios are read and stored using the Scenario 

Manager (under Tools). Up to 10 scenarios can be 

kept in memory for easy comparison. 

The Scenario Manager is used to load and unload 

scenarios from hard disk, to select a new scenario 

for the current view or to save a scenario, giving it a 

name, a label and a color for use in graphs compar-

ing variables from diff erent scenarios, an option 

available by selecting the scenario dimension in the 

Widget dialog. 

Another option to compare scenarios (and the only 

one available when dealing with maps) is to split the 

window into several panes showing the same graph 

for diff erent scenarios. 

The variables to be stored or read, and the fi les to 

be used for this purpose, are specifi ed in a template 

that is stored in a fi le named modelname.sce in the 

same directory where the model is located. This 

template can be parameterized. 

The Scenario Manager uses the scenario name 

to instantiate the fi rst parameter in the template. 

Depending on the use of the parameter in the tem-

plate, scenarios can thus either be stored in diff erent 

directories or with diff erent fi lenames or extensions. 

See Appendix C of the MyM GIM Reference Manual 

for full details. 
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File formats18. 

MyM uses several fi le types, each of which is char-

acterized by its own extension. Some of these fi les 

should never be changed by the user (.VDF, .MCM, 

.MDL), others will have to be created and main-

tained by the developer of a MyM model: 

a • model specifi cation in a fi le model.m (see Lan-

guage Reference), 

a • scenario template in model.sce (see Appendix C 

of the GIM Reference Manual), 

raster•  or vector maps in .VSF or .RSF fi les (see Ap-

pendix D of the GIM Reference Manual). 

For more information about data formats consult 

the MDIO document and the Data Specifi cation 

information on the MyM website. 
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